Adding Query-able fields

Home Forums User Forum Adding Query-able fields

Tagged: 

  • This topic has 5 replies, 2 voices, and was last updated 2 months ago by Will Gelnaw.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #5171
    Will Gelnaw

    I’d like to include some data on tags that isn’t currently a field that can be searched in my Query building menus. In particular, I’d like to add Determination Qualifier so I can have the appropriate cf. or aff. designations on tags. I already have it in my Determination form so I’ve been entering those data, but how do I make that an option in a query?

    #5470
    Will Gelnaw

    I found part of the solution. In the query window, right clicking on the Create Query text at the top of the side bar opens up the option to configure query creators. From there, you can add fields to be query-able. However, not all fields are available in this list, so adding Determination Qualifier still isn’t an option.

    #5471
    arountre

    Hi Will,
    In the querybuilder.xml file (in config folder), find the section that looks like this:

    <table name=”Determination” field=”determinations” title=”Determinations”>
    <alias name=”Taxon”/>
    <alias name=”Taxon” field=”preferredTaxon” />
    <table name=”DeterminationCitation” field=”determinationCitations”>
    <alias name=”ReferenceWork”/>
    </table>
    <!–<table name=”DeterminationStatus” field=”status”/>–>
    <alias name=”Agent” field=”determiner”/>
    <alias name=”Agent” field=”createdByAgent” />
    <alias name=”Agent” field=”modifiedByAgent” />
    </table>

    and add this line below the last line starting with <alias name=

    <alias name=”Determination” field=”qualifier” />

    -Adam

    #6232
    Will Gelnaw

    Thanks Adam.
    I got my network admin to let me change the config file as you suggested, but that doesn’t appear to have changed anything in the Query window in Specify? I restarted Specify. Is there anything else I need to do to make the changes take effect?
    – Will

    #6233
    arountre

    In System->Schema Configuration Edit Configuration, check to see if the qualifier field is hidden (choose determination table in the upper left box, then click on “qualifier” in the lower left box). If the “Hide Field” box is checked, uncheck it and click OK.

    If that isn’t the problem, I’m not sure what it might be. Qualifier shows up for me in queries following the query path Collection Object -> Determinations -> Qualifier.

    #6234
    Will Gelnaw

    Thanks again Adam. That did the trick.
    – Will

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.