
Specify	
  6:	
  Reports	
  and	
  Labels	
  
The purpose of this document is to provide solutions to common report needs and to address 
recurring stumbling blocks of Specify iReport users. Covered below are some of the basic 
elements of creating reports and labels, beginning with the Specify Query Builder and 
continuing with more in-depth examples of iReport capabilities.   
 
The iReport capabilities discussed within this document include: 

• Constructing expressions with the Expression Editor 
• Mixed concatenation 
• Styles 
• Images 
• Barcodes 
• Report groups 
• Scriptlets 
• Variables 
• Page orientation bug workaround, and other tips 

Creating	
  a	
  Query	
  for	
  the	
  Report	
  
Creating a query in Specify is the first step in defining the fields and data for a report or label.  
Pulling the correct data without unwanted repetition or duplication is often addressed in this 
initial step, along with other options like sorting records. Saving a query in the Specify Query 
Builder will immediately make it available for use in Specify iReport. 

 



Note: Data sets from the Specify Workbench can also be used for creating reports, but the 
capabilities are somewhat more limited than when using queries. A report based on a data set 
rather than a query has fields that are less easily manipulated and it will only run data from the 
data set rather than the entire database. However, the capabilities within Specify iReport are the 
same when working with either data set- or query-based reports. 

Fields	
  that	
  cause	
  duplicates	
  
Certain fields and tables are likely to cause duplicate labels or records to run.  For instance, 
labels based on a Collection Object query are prone to duplicating when there are multiple 
Preparations, Determinations, or Collectors associated with the single Collection Object record.   
 

Solution: Add the entire table to the query as an aggregated field instead of adding 
individual fields from that table.   
 
For instance, instead of adding ‘first name’ and ‘last name’ from the Collectors Agent 
table to a query, double-click ‘Collectors’ to add it to the query as an aggregated field.  
Upon applying the ‘Collectors’ field to the report, a list of collector agents will be 
displayed instead of several record details for each different collector. 

 

 
 
Multiple Determinations should be handled differently; add the “Current” field to the query, 
setting the criteria to “Yes”.  This way, only the current determination will print a label.  Make 
sure that the “Always” condition is checked so that this condition is used when running the label 
from record sets, query results, etc.  See screenshot below. 

 



 
 

Sorting	
  Label	
  or	
  Report	
  Contents	
  
To sort the results of a query (and report) use the Sort button to the right of the field criteria box. 

 

iReport	
  Basics	
  
Specify iReport is simplified for Specify users, because the datasource connections are already 
created, so a JDBC connection does NOT need to be set up. Furthermore, the report fields can 
be easily manipulated (added/removed) in the Specify Query Builder rather than using SQL 
queries.  
 
Getting started  

• Log in to Specify iReport under the same username that was logged in when saving the 
query.  Queries are only available in Specify iReport to the user who built them. 

       
 



• If there are multiple disciplines in the database, select the discipline that the query is 
saved in or intended to be saved in.  

 

 
• Once iReport has launched, access the query that is saved in Specify and begin creating 

your report by selecting File>Report Wizard or using this button:  

       
 

• A list of available queries will display. After selecting your query from the list, the Report 
Properties window will open (shown below). 

 



       

Report	
  Properties	
  
You will probably have to refer back to Report Properties frequently in the process of creating a 
report in order to set and modify, among other things: 

• Page size and orientation 
• Margins 
• Columns 
• Scriptlet class 

 
Click OK to confirm Report Properties, and the blank report template will appear. To get back to 
the Report Properties utility, click Edit in the toolbar and select Report Properties from the 
dropdown menu. 

Report	
  Bands	
  
The template for a new report will look similar to the screen capture below. The available bands 
include Title, Column Header, Detail, Summary, and others, which can be expanded or 
minimized by dragging the horizontal lines up or down. (NOTE: Band height can also be set by 
right-clicking the report template, selecting Band Properties, and entering the height in pixels. 
This is especially useful once a band has been minimized, if it needs to be expanded again.) 



 
The Detail band is an important template aspect with which to be familiar.  Any query field that 
you place in the Detail band will be filled with values from each record used to run the report. 
For loan invoices and specimen labels, the Detail band generally contains Collection Object 
data. The other bands, such as Title and Summary, will only display record data one time for 
each report and usually include such data as title, date, agent information, and institution 
information.   
 
Labels often only consist of the detail band, with all of the other bands minimized to zero. 

Adding	
  Fields	
  to	
  a	
  Report 
Fields that are saved in the query are listed in the Document Structure pane.  Expand the plus 
next to “Fields” to view all available fields for the report.  

 



(NOTE:  The Document structure pane should already be present on your iReport workspace, 
but if it is not, go to the toolbar and click View>Docking Panes>Document Structure.) 
 
Click on a field in the Document structure pane and drag it onto the report template to add it to 
the report.   

Saving	
  a	
  Report 
• To save changes to a report or label, go to the top toolbar and click File> Save. 

       
 

• A Save version of Report Properties dialog will pop up.   

       
 

• The uses of the Report Properties Save dialog are as follows: 
o Name: edit report name. 
o Report type: choose from Report, Label, or Invoice. This does not affect the 

report, it simply tells Specify which heading to put the report’s name under in the 
left-hand pane of the Reports page. 

o Save for: designate who can view the report in Specify, User or Discipline. 
o Repeats: the last option allows you to print multiple labels or reports by setting 

a constant number or by a numeric Specify field, such as the Prep Count field.  If 
you choose ‘By Field’ from the Repeats pick list, as many labels or reports will 
run as specified by the numeric value in that field.  Example of the ‘By Field’ 
option shown below. 



       
 

• Click OK to confirm the Report Properties.  After the report has been saved and closed, 
you can access it again in iReport by going to File>Open.  Make sure that you log in with 
the username under which the report was created. 

Using	
  the	
  Expression	
  Editor 
In iReport, the Expression Editor is used for editing single fields or combining multiple fields 
together in the same expression. To access it, right-click on a field that has been added to the 
report template, and select Edit Expression.   
 

 
 
Among other things, the Expression Editor lists the available fields below the editing box. 
Clicking on a particular field in the center column opens a list of possible field modifiers in the 
last column. The type of modifiers available depends on the type of field (i.e. string, integer, 
Boolean, etc.) Double-clicking a field will add it to the editing box. 
 



 
 

Avoiding	
  “null”	
  Values	
  in	
  Reports	
  and	
  Labels	
  
When a field is blank in the database, it will appear on the report or label in Specify as a “null” 
value.  This can be avoided with two different methods: 
 

1. The first and simplest option is to check “Blank when null” in the Properties pane on the 
right side of the screen. 

       
• The drawback of the “Blank when null” property is that it only works with a field that 

has not been edited with the Expression Editor.  For instance, if you are combining 
different fields into a single expression, or if there is static text (any text enclosed in 
quotation marks) in the box with the field in question, you will have to use the second 
option to avoid null values.  



 
2. The second way to avoid null values in a report is to use an ‘if null, then’ statement for 

each field, enclosed in parentheses. To use the ‘if null, then’ statement, right-click the 
desired field on the report template and select Expression Editor. The basic formula to 
use for the field is: 
 
($F{X}==null ? “”: $F{X})  
 
…which means: If the field ($F{X}) is empty, then print “” for: the field $F{X}.  
 
Applied to a date field in the Expression Editor: 

 
 
Note that any static text added in the expression after ? ””: will only print if the field is not 
empty. For example: 
 
($F{Date}==null ? “”: “Date: “+$F{X}) 
 
The above expression will print “Date: 08/22/2010” if the value in the field is 08/22/2010. 
If there is no value in the field for a given record, nothing will be printed. 
 

Basics	
  of	
  Expression	
  Writing	
  
1. Employ the ‘if null, then’ statement for any fields that may have null values in the 

database. 
2. Start and end parentheses should go around the entire ‘if null, then’ statement for 

separate fields, which should then be combined in the expression using a ‘+’ 
3. Combine dynamic fields and static text using a ‘+’  
4. Place quotes around a space, comma, label, or any other static text that should display 

with the dynamic fields. 
 
Sample: (Expression to display last name and first name fields as ‘Collector: John Smith’) 
 
 
 
“Collector: “ + ($F{First_Name}==null ? "": $F{First_Name} + “ “) + ($F{Last_Name}==null ? 
“”:$F{Last_Name}) 
 
 
 
 

‘+’ to combine fields 
and expressions 

quotes around static text  

‘if null, then’ statement, enclosed by 
parentheses 



Replacing	
  Values	
  Using	
  Modifiers	
  
The most common uses of modifiers for replacing values are for the Sex pick list and dates 
(loan date, collected date, cataloged date, etc.) Here are a few example scenarios: 
 

• A user wants sex pick list values of ‘M’, ‘F’, and ‘UN’ from the database to display as 
‘Male’, ‘Female’, and ‘Unknown’ on the labels.  The expression would appear as such: 

 
$F{Sex}.equals("M") ? "Male" : $F{Sex}.equals("F") ? "Female" : $F{Sex}.equals("UN") ? "Sex 
Unknown" : "" 
 

• A user is using a sex info field in Specify that can contain multiple values, such as ‘F’, 
‘Female’, ‘M’, ‘Male’, and perhaps other data.  Example of data in Specify: 

      
 

The user wants to use a symbol for the sex instead of text, with any other data in field 
displaying after.  So the expression must account for the multiple sex values: 

 
($F{Sex_(info)}==null ? "": $F{Sex_(info)}.replace("Female","♀").replace("F", 
"♀").replace("Male", "♂").replace("M","♂")) 
 
On the label, the data will display as: 

 
 

• Dates are saved in the database in the format “08/22/1994,” but the user wants their 
labels to display “22/Aug/1994.” The expression would then look like this: 

 
($F{Date_(Day)}==null ? “”: $F{Date_(Day)+”/”).toString()+($F{Date_(Month)}==null ? “”: 
$F{Date_(Month)}+”/“).toString().replace(“10”,”Oct”).replace(“11”,”Nov”).replace(“12”,”Dec”).repl
ace(“1”,”Jan”).replace(“2”,”Feb”).replace(“3”,”Mar”).replace(“4”,”Apr”).replace(“5”,”May”).replace(
“6”,”Jun”).replace(“7”,”Jul”).replace(“8”,”Aug”).replace(“9”,”Sept”)+($F{Date_(Year)}==null? “”: 
$F{Date_(Year)}+””).toString() 
 

• To make a date have zeros in front of one-digit numbers (ex: 2012/07/02 vs. 2012/7/2) 
use this expression: Note that for this report the order is year-month-day, which isn’t 
usual. You can change it around to make it whatever the institution wants. 

"Date: " + ($F{Loan_Date_(Year)}==null?"":$F{Loan_Date_(Year)}+"").toString() 
+($F{Loan_Date_(Month)}==null?"":"/"+(($F{Loan_Date_(Month)}+"").toString().length() == 2 ? 
($F{Loan_Date_(Month)}+"").toString(): "0" + $F{Loan_Date_(Month)}+"")).toString() + 
($F{Loan_Date_(Day)}==null?"":"/" + (($F{Loan_Date_(Day)}+"").toString().length() == 2 ? 
($F{Loan_Date_(Day)}+"").toString(): "0" + $F{Loan_Date_(Day)}+"")).toString() 
 

• For dates that are listed day-month-year, use the following expression: (replace the 
hyphens with slashes if you wish) 

 



"Det. Date: "+($F{Determined_Date_(Day)}==null?"":$F{Determined_Date_(Day)}+"-
").toString()+($F{Determined_Date_(Month)}==null?"":$F{Determined_Date_(Month)}+"-
").toString()+($F{Determined_Date_(Year)}==null?"":$F{Determined_Date_(Year)}+"").toString() 

Non-­‐string	
  Fields	
  in	
  Expressions	
  
All dynamic fields use an Expression Class that determines how they will be evaluated. Most 
dynamic fields from Specify are String, but some number fields can be Integer, Float, 
BigDecimal, etc. Fields of different classes are not compatible and, therefore, cannot be 
combined in a single expression without some extra steps.   
 

1. Right-click the non-string field and select Expression Editor.  Note that the field type is 
listed beside the fields in the Expression Editor. 

       
 

2. In order to combine a non-string field with static text, apply the modifier .toString(), as 
shown below: 

       
 

• When using an ‘if null, then’ statement with a non-string field, place the modifier after the 
parentheses. 

     
 
 

3. Apply the expression.   
4. Right-click the field again and select Properties. 



 
 

• In the Properties window, change the tab to Text Field. 

       
 

• Change the Text Field Expression Class to java.lang.String 



       
• Save the report. 

 
Note: If you have set a non-string field to String in iReport and are still getting an error related to 
the text field expression class (cannot cast from String to Integer, for example) when running the 
report in Specify, go back to the Expression Editor in iReport. If the field being set to String is in 
a simple ‘if null, then’ statement, like this: 
 
($F{X}==null ? “”: $F{X}).toString() 
 
try adding + “” to the second half of the parenthetical statement, like this: 
 
($F{X}==null ? “”: $F{X} + “”).toString() 
 
This should prevent the expression from causing errors in future. 

Mixed	
  Concatenation	
  	
  
Mixed concatenation refers to the combining of different font styles in the 
same expression. 
 
In the Expression Editor, use the following examples as guidelines. 
 
Replace the $F{X} with either the dynamic field or static text that is to be concatenated within a 
larger expression. If static text is to be concatenated, place quotes around it. 
 
For bold text: 
 
"<style isBold=\"true\" pdfFontName=\"Helvetica-Bold\">"+$F{X}+"</style>" 
 
For italicized text: 
 
"<style isItalic=\"true\" pdfFontName=\"Helvetica-Bold\">"+$F{X}+"</style>" 
 
For underlined text: 
  



“<style isUnderline=\”true\” pdfFontName=\"Helvetica-Bold\">"+$F{X}+"</style>" 
 
***Be sure to check “Styled Text” in Element Properties for the fields to display correctly 
in the report.*** 

  
 
NOTE: A bug within the iReport software prevents the mixed concatenation of expressions that 
use ampersands (in this case, the expression will display as basic html when running the report 
in Specify).  A Scriptlet called escapeForHtml can correct the problem.  See the section called 
“Further Insight into Scriptlets” for more details on this fix. 

Adding	
  a	
  Style	
  
Instead of spending time on selecting different style elements and properties for each individual 
field in your report, you can create styles to easily reuse or set as the default in the report.   
 

• Click on Format in the top toolbar and select Styles. 



       
 

• In the Styles window, click New.  The Add/modify style window results. 

       
 



• Change and add style properties to your liking – remember to give a Style name – and 
click OK.   

• The new style should now be added to the Styles window.  If you wish this style to be the 
report default, highlight it and click the Set as Default button.   NOTE: Changing the 
default will not change the style of fields already in place on the report template, so it 
should be set in the beginning of creating a report. 

       
 

• If you intend to use multiple styles in the same report, highlight a field that is placed on 
the report template and select from the Style dropdown in the Properties pane. 

       
• Save the report. 

Adding	
  Images	
  to	
  Reports	
  and	
  Labels	
  
Unlike word processor documents, iReport templates call images from a location on the 
computer; images cannot be pasted into the report template. For this reason, it is important to 
consider whether the report will be run on only one computer or multiple computers. If the report 
is going to be used on only one computer, then the image is most easily browsed and selected 
directly from within iReport.   



 
If the report will be used on more than one computer, the image should be defined in two places 
(which ultimately eases setting image locations on multiple computers). The image location is 
designated in Specify and the image name is designated in iReport with the addition of a 
parameter. 
 
Furthermore, by adding an extra parameter, there is the added capability of selecting a different 
image whenever running a report in Specify.  Those directions are covered in Part 3 of this 
section and are NOT necessary for users who only ever want to use one image in a given 
report. 
 
Images in Reports on a Single Computer 
Click the Image tool button  and size the image box on the report. 

 
 

• Right-click the image box and select Properties.  In the Properties window, change the 
tab to Image. 



       
 

• Under the Image Expression text box, click Find and select the specific image file 
location on your computer.  
 

Images in Reports on Multiple Computers 
 
Part 1: Designating the image name and parameter 

• Follow the same directions as for a single computer, but leave the Image Expression 
blank for now instead of clicking Find. 

• Close Properties. 
• Click View in the toolbar and select Parameters. 

       
 

• Click New. 



       
 

• Type RPT_IMAGE_DIR for the Parameter Name.  

       
• Click OK and Close Parameters. 
• Again, right-click the image icon on the report and select Properties.. 
• Under the Image tab, click the Expression Editor button located next to the Image 

Expression text box.  
• In the Expression Editor, use the following expression (inserting your own image file 

name with extension where it says “filename.jpg”): 



       
• Apply the expression and Save the report. 

 
Part 2: Designating the image location 

• To designate the Reports Image Location, open Specify.  Click Edit in the topmost 
toolbar and select Preferences.  

       
 

• Change the view to System.  Under Report Images Location, browse for the standard 
location where your report image file will be placed. 

       
 

• Save the change and the image should be ready to run in your report. 
 
 
Part 3: To allow the selection of an image at the time of running the report 



This extra step allows you to select your label upon running the report in Specify instead of 
designating just one image to be used every time. 

• Complete the instructions in Part 2 (for multiple computer use). 
• Open iReport.  Click View in the topmost toolbar and select Parameters.  Click New. 
• Name the Parameter ‘image’ for example.  Check ‘Use as a Prompt’. (In this window, 

you can also set a default image filename that will be used if you do not designate a 
different image when running the report.) 

 
 

• Click OK and close Parameters. 
• Right-click the image icon on the report and select Properties.  
• Under the Image tab, click the Expression Editor button located next to the Image 

Expression textbox.  Enter the following expression: 

       
• Apply the expression and save the report. 
• Open Specify and go to Reports. 
• Run Report.  When the Report Settings window appears, there should now be two tabs: 

Query Criteria AND Report Parameters. 



       
 

• Change the tab to Report Parameters.  Type the image filename that you want to use for 
the report.  (Remember, the image must be located in the same directory as set in 
Preferences.) 

   
 

• Click OK and the report will run with the selected image. 

Barcodes	
  
Adding a barcode to a label or report is a fairly straightforward process as long as you know the 
capabilities of the barcode scanner.  Any barcode that is available in iReport can be used on a 
label or report and run in Specify.  The value of the barcode is based on a Specify field, usually 
catalog number or invoice number.   
 
Note that QR Codes are not available for use in 3.0.0 version of iReport that Specify currently 
uses.  A plugin is available for this use but requires a licensing cost. 

• In iReport, click the Barcode tool button and size the barcode box on the report.  
• Right-click on the barcode once it is in place.  Select Properties. 
• Change the Properties tab to Barcode. 



 
 

• Select a type of barcode by choosing from the Type dropdown (see the next section for 
information about barcode types and compatibility). 

• To apply a field to the barcode, click the Expression Editor button next to the Barcode 

Expression textbox.   
• In the Expression Editor, select and add a field from the list of available fields.  An 

example is shown below. 

       
 

• Apply the expression and close the Properties window.  Save the report. 
 

NOTE:  Occassionally, in iReport, the barcode image will have a text overlay that says ‘Barcode 
Error’. The barcode should still run correctly in Specify and can be scanned with an appropriate 
barcode scanner. 

Barcode	
  Type	
  Compatibility	
  
There are certain barcode types that iReport cannot put into generic AlphaNumeric String 
format (for example, Catalog Numbers or Accession Numbers):  
 
(A) i.e. generates an error in the creation of the barcode from within iReport.  
2of7, 3of9, Bookland, Codabar, Code128C, Code39, EAN13, Int2of5, Monarch, NW7, Std2of5, 
UCC128, UPCA, USD3, USD4  



(B) In revision, some barcodes generate an error from within iReport, but the 
resulting report turns out fine.  
These are the following: 2of7, 3of9, Code128C, Code39, Monarch, NW7, Std2of5, USD3, 
USD4. Also, I tested these with only numeric values, even though some of them do not process 
alphanumeric strings. So, some of these barcodes may not work in those circumstances, but it 
is not a general error but rather simply an incompatibility. The flip side of this list (i.e. the 
barcodes that cause an error in the filling of the report from within Specify): EAN13, int2of5, 
UCC128, UPCA. 

Report	
  Groups	
  
Groups allow you to organize the records of a report to better structure the report content.  
Groups are especially valuable when making a loan invoice.  When a group is defined by an 
expression, a new group begins when the expression value changes (e.g. when a loan 
number changes, a new invoice begins for the new loan number).  Moreover, Groups are 
useful for making certain specimen labels and reports as well.  For instant, one application has 
been to list all associated Collection Object records for a single Taxon name – with the list of 
Collection Objects starting over with each new Taxon name. 
 

• To implement a Report Group in iReport, click View and select Report Groups.  

       
 

• In the New Report Groups window, click the New button.  The Add/modify group window 
will then open. 



       
 

• Enter a Group Name (e.g. Loan Group).   
• To define the Group expression, click the Expression Editor button next to the Group 

Expression textbox and select a field from the list of Specify fields available.   

       
 

• Apply the expression. 
• Select other features in this window--such as start on a new page or column with each 

new value for the Group Expression.  A finished example is shown below for reference. 



       
 
• Click OK at the bottom of the Add/modify group window and close the groups. 
• New Group Header and Group Footer bands should now be visible in the report 

template.   

 
 



Further	
  Insight	
  into	
  Scriptlets	
  
Scriptlets perform special Java functions that pull data from a Specify database and translate it 
into a given format in a report or label.  Scriptlets are predefined in the Specify 6 code and 
provide for a range of possible formatting issues that a collection might come across when 
making labels and reports.  Directions for use and a list of existing scriptlet functions in Specify 
6 can be found at http://files.specifysoftware.org/SpecifyScriptlet.html. There are some that are 
not currently on the list, including several that are explained in this document. 
 
Note: When using scriptlets in a report, make sure that the Scriptlet Class in Report Properties 
(Edit>Report Properties) is set to edu.ku.brc.specify.config.Scriptlet (see below). 
 

 
 
Scriptlets must be added to the Expression Editor in the following format: 
((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).scriptletName(required fields) 
 
The following examples are common use-case scenarios or further explanation for some 
existing scriptlets: 
 
Expression for formatted Latitude/Longitude and direction characters: 
To display latitude and longitude in the original format (as they are shown in Specify) and with 
direction characters (N, E, S, W), you would use the .formatLatLon and .getDirChar Scriptlets.  
The query fields necessary for these two scriptlets are latitude1, longitude1, and original latitude 
longitude unit. 
((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).formatLatLon($F{Latitude1}, 
$F{Original_Latitude_Longitude_Unit}, true) + 



((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).getDirChar($F{Latitude1}, true) 
+ " " + 
((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).formatLatLon($F{Longitude1}, 
$F{Original_Latitude_Longitude_Unit}, false) + 
((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).getDirChar($F{Longitude1}, 
false) 
 

The above expression displays as:  
 
To set Latitude and Longitude to appear blank when the value is null, follow these steps: 

1. In the left panel of iReport, right-click Variables and select “Add…” and choose Variable. 
2. In the Variable form, use these settings: 

o The name should be either “Latitude” or “Longitude.” Each needs its own 
variable. 

o Variable Class Type - String 
o Calculation Type - Nothing 
o Reset Type - Report 
o Increment Type - None 

3. Set the Variable Expression to one of these two, depending on whether the variable is 
Latitude or Longitude: 

o ((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).formatLatLon($
F{Latitude1}, $F{Original_Latitude_Longitude_Unit}, true) + 
((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).getDirChar($F{L
atitude1}, true)  

o ((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).formatLatLon($
F{Longitude1}, $F{Original_Latitude_Longitude_Unit}, false) + 
((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).getDirChar($F{L
ongitude1}, false) 



       
4. The Initial Value Expression should be “” 
5. In the field where you want the latitude and longitude, the expression will look like this: 

o ($V{Latitude}==null?””:$V{Latitude})+”, “+($V{Longitude}==null?””:$V{Longitude}) 



 
 
Remember to edit the field’s properties and ensure that the Text Field Expression Class is set to 
String, or you will get an error when you run the report. There are screen shots of creating a 
Variable in the next section of this document, if you run into trouble setting up the Lat/Long 
variables. 

Some	
  Commonly	
  Used	
  Scriptlets	
  
Scriptlet for mixed concatenation expressions using ampersands:  
 
DON’T FORGET TO CHECK THE STYLED TEXT BOX!!!!!!!!!!! 
 
 ((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).escapeForHtml($F{Author}) 
 
"<style isItalic=\"true\" pdfFontName=\"Helvetica-Bold\">" + 
($F{Genus}==null?"":((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).escapeFo
rHtml($F{Genus})) 
+ " " + 
($F{Species}==null?"":((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).escapeF
orHtml($F{Species}))  
+ "</style>" +  
($F{Species_Author}==null?"":((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).
escapeForHtml($F{Species_Author}))  
+ " " +  
($F{Variety}==null?"":" var. "+"<style isItalic=\"true\" pdfFontName=\"Helvetica-Bold\">"  +  
$F{Variety}+"</style>") + ($F{Variety_Author}==null?"":$F{Variety_Author})  
+ " " +  
($F{Subspecies}==null?"":" subsp. " + "<style isItalic=\"true\" pdfFontName=\"Helvetica-Bold\">" 
+ $F{Subspecies}+"</style>") + ($F{Subspecies_Author}==null?"":$F{Subspecies_Author}) 



 
Scriptlet for primary collector: 
((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).getFirstCollector($F{Catalog_N
umber}) 
 
Scriptlet for secondary collectors: 
((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).getSecondaryCollectors($F{Ca
talog_Number}) 
 
Scriptlet for calculating length of loan: 
((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).dateStringDifference($F{LoanD
ate}, $F{CurrentDueDate}) 
 
To retrieve agents by Loan Agent Role, use the following scriptlet: 
 
((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).getByLoanAgentRole($F{Loan
Number},”agent role”,”agent.field”) 
 
“agent role” is the role of the agent in the Loan that you are using. For example, if you are using 
the scriptlet for the agent who is the recipient of the loan, the role will probably be Borrower. Be 
sure to compare the loan record with the report to make sure you are using the correct role. 
  
“agent” refers to the table in which the field in question is located. For address fields, the table 
would be “address,” not “agent.” Make sure that the field names match the ones in the schema 
EXACTLY. To check this, go to Schema Configuration, select the agent or address table 
(depending on which field you are checking) and look at the Fields box (below the Tables box) 
to find the name of the field. Some examples of fields you might use are agent.firstName, 
agent.lastName, address.address, address.city, and address.state. Be sure to compare the loan 
record with the report to make sure you are using the correct fields. 
 
*Note: if you use this scriptlet, you do not need to include the Loan Agent fields it calls for in the 
query. Also, this scriptlet only works for agents added to a Loan record under Loan Agents. It 
will not work for agents in Shipped To or Shipped By. 
 
To format Preparations to match the format on the default invoice: 
($F{Quantity}==null?"":$F{Quantity}+"").toString() + " " + 
($F{Prep_Type}==null?"":$F{Prep_Type}+"") +  " of " + 
((edu.ku.brc.specify.config.Scriptlet)$P{REPORT_SCRIPTLET}).calcLoanQuantity($F{Count}, 
$F{Quantity_Returned}, $F{Quantity_Resolved}) + " " + 
($F{Prep_Type}==null?"":$F{Prep_Type}+"") 
 
This will print preparations in this format (under Specimen Count): 

 
 
 
 
 



 
Variables	
  
	
  
If you’re just trying to say how many records are on an invoice, try adding the field 
“NumberOfRecords) before making a variable. If it worked, it turns out to be a way easier 
solution then messing with this stuff. 
  
Variables are objects used to store the results of calculations such as subtotal and sums.  In this 
section, two examples are given of creating two different variables that are commonly used in 
Loan Reports – but they can be of use elsewhere.  Other variables are built into iReport, but are 
not modifiable by the user.  Built-in variables are listed in the Library pane and can be dragged 
to the report.  See below for the built-in variables that are available. 

  
Calculating a Distinct Count 
For example, a user may want a count of the species being loaned to appear on a loan invoice.  
Follow these steps: 

• In the Document structure pane of iReport, right-click “Variables”.  Hover your mouse 
over “Add” and click “Variable”(shown below). 

       
 

• The “Add/modify variable” window allows you to define your variable.  Use the given 
criteria in the listed fields and use the screen capture as reference. 
o Variable Class Type: java.lang.Integer 
o Calculation Type: Distinct Count 
o Reset Type: Report 
o Reset Group: leave blank, unless you are using a Report Group and want only one 

group to be used for the calculation. 
o Increment Type:  None 
o Increment Group: leave blank, unless you are using a Report Group to specify when 

the variable value has to be evaluated. 
o Variable Expression:  Click the Edit button next to the text box and select the field 

that should be counted distinctly.  In this scenario, the Taxon Full Name is being 
evaluated. 



 

       
 

• Click OK.  Once the Variable has been created, it will be available under “Variables” in 
the Document structure pane.  Drag the variable onto your report as if you were adding a 
field to the report. 

 
Calculating a Sum 
A user may want to calculate the total specimens being loaned to appear on a loan invoice. 

• Follow the same directions as given above for a distinct count with the exception of 
the changed criteria for Calculation Type and Variable Expression.   Use the screen 
capture below for reference. 

o Calculation Type: Sum 
o Variable Expression: click the Edit button next to the text box and select the 

field that should be calculated for a sum.  In most cases, the Count field (or 
its equivalent) from Loan Preparations is evaluated for the sum of specimens 
being loaned.  

 



 

Labels:	
  Manually	
  changing	
  page	
  orientation	
  to	
  portrait	
  (work-­‐
around	
  for	
  iReport	
  bug)	
  	
  
An active iReport bug does not allow page orientation to be set as portrait when the page length 
is greater than the height – iReport automatically changes the orientation to landscape.  This is 
problematic for some user’s printing requirements, especially in regard to labels.  To manually 
change the orientation to portrait, follow these directions: 
 

• When the label is in its final draft, check the Page Size in Report Properties (Edit > 
Report Properties).  Make sure the dimensions are correct even though the orientation is 
incorrect.   

• Open Specify and go to System, located on the top toolbar.  Open Resource 
Import/Export from the System dropdown.   



       
 

• Make sure that any changes in Specify have been saved and click Continue to the dialog 
below. 

       
 

• Reports are usually located under the Discipline level, so change the pick list to 
“Discipline” and change the tab to “Report Resources” to see your report.     

       
 

• Highlight your report or label and click the Export button.  Export the report or label to a 
location on your computer as a zipped file by adding the .zip extension to the filename 
(e.g. Example.zip). 



• Go to the zipped file on your computer and unzip it.  The unzipped folder will contain 
three xml files.   
 

 
 

• Open the data.xml file with a word processor such as Notepad in order to edit it.  (On 
Windows, right-click data.xml and select “Open With” Notepad.) 

• The file document will look something similar to the screen capture below.  Find 
orientation=”Landscape”, located close to the top of the page. 

 
 

• Change “Landscape” to “Portrait”.  Save your changes.  
• Rezip the entire folder.   
• In Specify, go to System > Resource Import/Export and import the zipped file to 

Discipline level, under the Report Resources tab. 
NOTE:  Once the orientation has manually been changed, do not edit the orientation for the 
label from within iReport. 
 
 
 



Another thing you might have to do: 
 When you run the report in Specify, click Print and go to the printing options. Mess 
around with the orientation and size there (make the label just under 2 inches in iReport if the 
printer has it set to be 2 inches high OR try making the label print upside down by making the 
orientation be Portrait x 180) 

Tips,	
  Tricks,	
  and	
  Workarounds	
  
Disappearing text boxes: 
If text boxes are visible on the report template but not showing up when the report is run in 
Specify, check the font size and text box size. The usual culprit is height: the text box should 
have a height at least three pixels greater than the point size of the text entered in the box.  

 
For example, if the text is Arial 12 pt. font, the text box should be at least 15 pixels tall for one 
line of text. It is not necessary to add three pixels for each line of text if the box has multiple 
lines, but it is a good idea to leave some extra room if possible. 
 
Issues with changing line thickness and text box size in the Properties pane: 
Due to a bug, iReport sometimes does not change graphic line thickness or text box size when 
these numbers are entered in the Properties pane on the right side of the screen. To change 
line thickness, set the line thickness (the default value is 0) to 1, and then re-set it to the desired 
line thickness.  



 
If iReport is not saving changes to text box size, try opening the Properties pop-up window 
(right-click the text box and select Properties) and changing the numbers that way. 
Restarting iReport may be required if it is still impossible to make changes. 
 
Resizing the page, columns, column spaces, and report bands: 
When making labels, it is necessary to match the sizing and spaces exactly to a sample page, 
which may be printed from MS Word, Specify 5, etc. Unfortunately, iReport’s Report Properties 
window is not as accurate as is sometimes required. To get the exact size you need for the 
template margins, columns, column spaces, and report bands, use these methods: 

- Margin width, column width, and column space width can all be adjusted one pixel at a 
time in the Properties pane on the right size of the iReport window. 

 



- Band height can be adjusted one pixel at a time by going to View>Bands, selecting the 
Detail band (or another band, if you are not using Detail,) entering a height in the box, 
and clicking Apply. 

 

Using	
  Your	
  Report	
  or	
  Label	
  in	
  Specify	
  
Once the report has been saved in iReport, it can be used in a variety of contexts in the Specify 
application. 

• Log into Specify. 
• Click on the Report tool. 

 
 
• In the Reports tool, your report or label will be placed in the left-hand side menu under 

the applicable heading - Reports or Labels.   
 
• After making changes to a report in iReport, click Refresh to see changes when running 

the report.  During the process of creating and editing a report, this Action will be 
repeated over and over again. 

 
• To Run a report from the Reports tool:  
1. Under the Actions heading in the left-hand side menu, click ‘Run Report’ to select from a 

list of available reports OR 
2. Click directly on the report OR 
3. If record sets are available, they can be dragged and dropped on a report name to run it. 

 



In the first two scenarios listed above, a Report Settings window will appear, displaying the 
queried fields for the report or label.  From this window, you can turn on/off sorting, change 
operators, and enter criteria to be searched and then displayed in the report.  

 
 

• Other contexts within Specify for running reports:   
o The Search Results toolbar contains a Report View tool 

that can be used for all given search results or just 

highlight-selected results.  

 
 

o From the Collection Object or Loan forms.   

 
o From the Workbench left-hand sidemenu. 



 
 
 

Getting	
  rid	
  of	
  an	
  extra	
  blank	
  page	
  in	
  a	
  report	
  
 
This happened to me when I was working on a label. I’m not sure why, but changing the drop 
down menu from ‘vertical’ to ‘horizontal’ in the ‘print order’ option on the ‘more…’ tab in Report 
Properties fixed the problems. I think I had to save and refresh the report a few times for the 
change to take place though. 
 

Getting	
  rid	
  of	
  extra	
  punctuation	
  when	
  fields	
  are	
  null	
  
 
For example, you don’t want a report to look like ‘South America, Paraguay , , , ‘ if the rest of 
some of the fields in the middle of the expression are null. To only make extra punctuation or 
even words show up only when there is information in the field, format like this: (example) 
 
($F{Continent}==null?"":$F{Continent})+($F{Country}==null?"":", " + 
$F{Country})+($F{State}==null?"":", " + $F{State})+($F{County}==null?"":", " + 
$F{County})+($F{Locality_Name}==null?"":", " + $F{Locality_Name})+($F{Latitude1}==null?"":", 
" + $F{Latitude1}+"°").toString()+($F{Longitude1}==null?"":", " + $F{Longitude1}+"°").toString() 
 
Insert your own fields or do whatever you want, but this should work perfectly.  
 



	
  

Making	
  dates	
  have	
  extra	
  zeros	
  
 
For example, you date looks like this 2012/7/9 and you want it to look like 2012/07/09. Note that 
the format is year/month/day here, you can switch it around as you wish. Use this expression:  
 
"Date: " + ($F{Date_(Year)}==null?"":$F{Date_(Year)}+"").toString() 
+($F{Date_(Month)}==null?"":"/"+(($F{Date_(Month)}+"").toString().length() == 2 ? 
($F{Date_(Month)}+"").toString(): "0" + $F{Date_(Month)}+"")).toString() + 
($F{Date_(Day)}==null?"":"/" + (($F{Date_(Day)}+"").toString().length() == 2 ? 
($F{Date_(Day)}+"").toString(): "0" + $F{Date_(Day)}+"")).toString() 
 
 

Making	
  dates	
  display	
  full	
  month	
  names	
  instead	
  of	
  numbers	
  
 
 
 
($F{Collection_Date_(Day)}==null?"":$F{Collection_Date_(Day)}+" 
").toString()+($F{Collection_Date_(Month)}==null?"":$F{Collection_Date_(Month)}+" 
").toString().replace("10","October").replace("11","November").replace("12","December").replace
("1","January").replace("2","February").replace("3","March").replace("4","April").replace("5","May
").replace("6","June").replace("7","July").replace("8","August").replace("9","September") 
+($F{Collection_Date_(Year)}==null?"":$F{Collection_Date_(Year)}+"").toString() 


